Playing with Adobe CS6 While Working on the Launch of my Beta Program

MariaVideoSnapShot

As I mentioned on a previous post, I just launched a beta program for my Jewelry Assembly Management System. For the landing page, I wanted an introductory video with some cool effects, and while that was not necessary at all (the cool effects), I thought it would add some spice. I also though that using an After Effect template that I got from Envato, would make the little side project easy.

Well, I was so wrong. You see, I have the Adobe CS6 Cloud subscription, so I wanted to start playing with all my new toys (I use only a few of the programs in the suite on a regular base).

I have never used After Effects before, and it’s a huge monster. I started watching some video tutorials on the Internet, but they were going to fast. Finally I found some just right paced tutorials at mamoworld.com.

So, I create some text slides in Photoshop, put them in the template, edit a few things here and there, etc. Maria, my wife, recorded the audio and sent it to me and then I synced the video and the audio  and I added some background music. It was much more work than I would expect, but it was done. Now rendering time. Oops. It took forever, like 15 hours… and it crashed. So I have to start the rendering all over again.

I decided to render the video again at 720p instead of full HD. It took less time to render, but again it was painfully slow, around 7 to 8 hours. This time the render seemed to work OK. Time to watch it on a video player. Bummer! the video was playing OK, but it had no sound. What did I do wrong? I have no clue.

Well, I was not going to re render it on After Effects, since I din’t know the cause of the problem. Time to experiment with another possible solution. So, I started Premiere, added the video and the 2 sound tracks (the voice narration and the music background), adjusted the tracks accordingly and rendered the video again. This time it took around 3.5 hours. Al little better, but still very slow, considering I have a Intel Core i7 machine with 8GB of RAM and a good GPU. What is interesting is that the video produced by AE was around 230MB and the one produced by Premiere around 1.05GB. WOW, huge difference. But who cares. This time it worked.

Did it turn out as I expected? Not exactly, but this video was not really critical for the Beta launch. It’s just a teaser of why a jewelry designer would like to try the program. I guess the video is just OK. Once out of Beta, I will need to make my videos look more “professional”. Eventually I will get there.

Do you want to see the final result? Check it out below.

Then, it was time to make a video showing how to use the Jewelry Assembly Management System. Basically, I needed to record my screen while showing how to accomplish the tasks. I downloaded a trial version of Snagit, and recorded the video. I wanted to include a title at the beginning at another at the end and add background music. This time I decided to work with the video features in Photoshop CS6. I created a new layer and added the initial title, included it on the same group as the video, made a copy of that layer and changed a word, and added the music sound track. I rendered the video (it took around 1 hour) and all done.

Again, I am not fully satisfied with the result, but it’s not too bad. I guess practice will help improving my video editing abilities … and my narration abilities.
Here is the final video:

What do you think?

Do you have some recommendations or pointers that will allow improving the process?


UA-4365634-1